Problems with SLIP


Dieter Woerz (mcvax!unido!iaoobelix!woerz@uunet.uu.net)
16 Jun 88 15:56:14 GMT


Hello,

I had posted some time ago on comp.dcom.lans, but didn't get some
satisfactory answers, so I decided to post this to the TCP/IP-wizards
group in the hope to get more help.

I have installed the program between a Sun 3/50 running SunOS 3.4 and a
VAX 11/750 running 4.3BSD, but we have some severe problems with the
connection. May be you can help me.

My scenario is the following (Class B network 129.69, Subnetmask
0xffffff00):

+--------------------+ +--------------------+
|Sun3/50 (SunOS 3.4) | |VAX 11/750 (4.3BSD) |
| | sl0 sl0 | |
| Slip IP .135.2 +-------------------------+ Slip IP .135.1 |
| | | |
|Ethernet IP .134.2 | |Ethernet IP .133.1 |
+---------+----------+ +---------+----------+
          | |

1. I can rlogin from the VAX to the Sun (Added routing info man-
    nually)
2. There is no exchange of routing info between the Sun and the VAX.
3. I can't connect directly to any node on the Ethernet connected to
    the Sun from the VAX.

My netstat on Sun looks like that ((*) has been added manually)
Destination Gateway Flags Refcnt Use Interface
129.69.135.0 129.69.135.2 UH 0 4278 sl0
129.69.135.1 129.69.135.2 UH 3 666 sl0
129.69.135.2 129.69.135.2 UH 0 0 sl0
129.69.134.0 129.69.134.2 U 10 35523 le0
129.69.135.0 129.69.135.2 U 0 0 sl0
129.69.0 129.69.134.2 U 2 4280 le0
default 129.69.135.2 U 0 6974 sl0 (*)
127.0.0 127.0.0.1 U 5 4989 lo0

After the startup, the netstat on the VAX looks like this:
Destination Gateway Flags Refcnt Use Interface
129.69.133.1 127.0.0.1 UH 0 69 lo0
127.0.0.1 127.0.0.1 UH 0 0 lo0
129.69.135.2 129.69.135.1 UH 1 10 sl0
129.69.135 129.69.135.2 UG 3 547 sl0
129.69.133 129.69.133.13 UG 0 0 de0
129.69 129.69.133.1 U 0 49 de0

When the routing table entries have timed out, it looks like that:
Destination Gateway Flags Refcnt Use Interface
129.69.133.1 127.0.0.1 UH 1 153 lo0
127.0.0.1 127.0.0.1 UH 0 0 lo0

Then, I have to manually reconfigure the interfaces and add the routes,
which are marked with a (*)
Destination Gateway Flags Refcnt Use Interface
129.69.133.1 127.0.0.1 UH 1 217 lo0
127.0.0.1 127.0.0.1 UH 0 0 lo0
129.69.135.2 129.69.135.1 UH 0 3 sl0
129.69 129.69.133.1 U 0 45 de0
129.69.134 129.69.135.1 U 1 327 sl0 (*)

I hope, someone can help me correcting my problems.
If someone needs more information, please contact me.

Please reply by mail, because I think this is not in the interest of many
other readers of this newsgroup.
If there is interest, I will post a summary to both comp.dcom.lans and
comp.protocols.tcp-ip, as soon as the link is working as desired.

Thanks in advance

--
------------------------------------------------------------------------------

Dieter Woerz Fraunhofer Institut fuer Arbeitswirtschaft und Organisation Abt. 453 Holzgartenstrasse 17 D-7000 Stuttgart 1 W-Germany

BITNET: iaoobel.uucp!woerz@unido.bitnet UUCP: ...{uunet!unido, pyramid}!iaoobel!woerz



This archive was generated by hypermail 2.0b3 on Thu Mar 09 2000 - 14:42:30 GMT