TLI HELP!!!


Gil Widdowson (mtune!codas!ablnc!gil@rutgers.edu)
18 Mar 88 16:13:10 GMT


I need some help with WIN/3B 2.1 and UNIX 5.3.1 TLI. I have an
application that worked with both the TLI and sockets interface
under WIN/3B 1.1. I have had to make some changes to make sockets
work under 2.1, but I can not get even get to first base with
TLI. The AT&T TLI documentation describes things at a generic
level since it does not know anything about the transport
provider you will be using. Unfortunately, the WIN documentation
that I got, does not address what data structures need to be
used. Is it still the sockets structures such as sockaddr_in when
you deal with network addressing.

Here is the problem I have now. I am trying to send a datagram. I
do a t_open() and get a stream with a service type of T_CLTS
according to the info returned to me. I do a t_bind(fd, NULL,
&ret) and seem to get a port. What is the format of the eight
byte ret.addr.buf returned? I am getting back what looks like a
the port id in the first four bytes and zeroes in the last four?
For ha-has, I do a t_getstate() before the t_sndudata() and it
says the stream is in the idle state. Then when I attempt the
t_sndudata(), I get

errno 203 Socket operation on non-socket

A rather strange TLI error. I am using the same udata structure I
used under WIN/3B 1.1. This uses a sockaddr_in structure to
define the destination address for the datagram.

I would appreciate ANY help. I would really like some working
code fragments using TLI and poll() to manage multiple stream I/O
in the same process. Additional documentation references would
also be appreciated. I currently have:
UNIX Sys V programmer's ref and guide
UNIX Sys V Network programmer's ref
UNIX Sys V Streams programmer's ref
Enhanced TCP/IP WIN/3B Reference Manual for release 2.1

Please reply via email to ihnp4!ablnc!utiprod!gil.

thanks,
gil widdowson
AT&T
(305) 660-6123



This archive was generated by hypermail 2.0b3 on Thu Mar 09 2000 - 14:41:06 GMT